Loading GPS trail data to follow on your GPS device is easy - just find your device in the list below and follow the instructions.


Garmin Edge 605/705
  1. Connect your GPS to your computer via USB
  2. Navigate to the 'Garmin/GPX/' memory folder and copy the file to the GPS
  3. Turn on your device and press menu. Navigate to Where To -> Saved Rides.
  4. Select the track from the list and choose "Navigate."

Alternatively you can follow the instructions for the Edge 205/305 listed below.

Garmin Edge 205/305
  1. Download the latest version of Garmin Training Center from garmin.com (free).
  2. Choose File -> Import History and select your GPX- or TCX-formatted file (.gpx, .tcx).
  3. Find the ride in your history list (singletracks files will be listed under the date the file was downloaded).
  4. Right click on the ride and choose "Create Course from Activity" ("New Course from History" on the Mac version).
  5. Choose File -> Send to Device and wait for the data to transfer to your GPS device.
  6. On the GPS, go to Main Menu -> Training -> Courses. Select the appropriate course, the choose "Do Course."

More detailed instructions are available for both PC and Mac versions of Garmin Training Center software.

Garmin Colorado
  1. Connect GPS to your computer via USB. Navigate to the 'Garmin/GPX/' memory folder and copy GPX files over.
  2. Go to main menu -> Where to -> Tracks and select the track you wish to use.
  3. You can also load KMZ files by placing the files in the 'Garmin/KMZ' memory directory.

Garmin GPSmap 60 and eTrex (Using Garmin MapSource)
  1. From the menu, choose File -> Open. Select "GPS eXchange Format" from the "Files of Type" menu in the dialog. Select the GPX file you'd like to load.
  2. After loading the GPS track and waypoint data you'd like to transfer, choose Transfer -> Send to Device from the menu.
  3. Select your device and check the "Track" and "Waypoint" checkboxes.
  4. From the main menu, select "Tracks." Select the track you wish to follow, then select the "TracBack" button. More detailed instructions can be found here.
  5. Many third party GPS software applications allow you to transfer track data to and from most Garmin devices. For specific instructions on transferring GPX data, please consult the software user manual.

DeLorme PN-series
  1. Using DeLorme's Topo USA software, select the "Draw" tab, then click the "Import" button. Set the file type input to Files of Type: GPX.
  2. Select the track file from the list. Click "More." Right click on the track and choose "Manage Draw" then "Send to GPS." Use the control or shift key to select multiple tracks.
  3. Click the send button.
  4. You can also select a track directly on the map. Right click on the track and choose "Manage Draw," then "Send to GPS."